浙江| 临桂| 平乡| 新和| 大龙山镇| 扎赉特旗| 嘉禾| 西沙岛| 墨竹工卡| 泰安| 喀什| 彭泽| 北海| 仪征| 永昌| 汨罗| 黄岩| 赣榆| 怀安| 薛城| 阿鲁科尔沁旗| 长白山| 太谷| 利津| 玉溪| 孟州| 南平| 濉溪| 青河| 绛县| 神池| 萨迦| 定南| 苏尼特右旗| 宽城| 桓仁| 武山| 郓城| 密山| 繁峙| 宜宾县| 临漳| 大连| 理县| 西乡| 阳山| 白碱滩| 丹凤| 翼城| 安阳| 社旗| 龙湾| 广东| 阿勒泰| 北辰| 扶余| 永昌| 三台| 门头沟| 永平| 科尔沁右翼中旗| 平安| 宝清| 浮山| 浮梁| 旌德| 通渭| 长治县| 建宁| 高陵| 太白| 甘泉| 扬中| 珊瑚岛| 龙泉| 长乐| 北流| 玉林| 宁南| 河池| 崇州| 纳雍| 松阳| 绥宁| 庆云| 垦利| 哈巴河| 茄子河| 田东| 丰润| 宁南| 偃师| 昌平| 横山| 沽源| 丹寨| 牙克石| 大理| 常宁| 泗洪| 二道江| 丽江| 林西| 尉氏| 黔江| 天峻| 辉县| 白城| 甘肃| 平南| 湖南| 汤阴| 德令哈| 托里| 泉港| 辽中| 浮梁| 伊春| 海安| 格尔木| 白云矿| 西吉| 项城| 咸阳| 珊瑚岛| 郧县| 江永| 武冈| 富蕴| 勐海| 上饶市| 东台| 岳池| 孝义| 夏县| 烈山| 越西| 清苑| 拜城| 长泰| 丹棱| 承德县| 双辽| 孟州| 资溪| 昭通| 壤塘| 东西湖| 兴义| 宝丰| 杂多| 五通桥| 朝天| 双柏| 定边| 南陵| 西山| 鹿寨| 泰兴| 天峻| 原平| 瑞安| 交口| 察雅| 巫溪| 井陉矿| 抚远| 深圳| 三亚| 平度| 宁波| 莫力达瓦| 包头| 天门| 坊子| 巴彦| 苍南| 五台| 台东| 文县| 黔江| 丘北| 庆云| 开封县| 临夏市| 静乐| 宿豫| 虎林| 开原| 民权| 江孜| 蚌埠| 武进| 开化| 云县| 靖西| 围场| 富县| 嘉峪关| 石家庄| 诸城| 五峰| 安多| 绥化| 繁峙| 上犹| 思南| 同江| 新竹县| 大方| 乌审旗| 宣化县| 石首| 白银| 秭归| 介休| 西华| 茶陵| 固始| 瓮安| 金华| 黟县| 科尔沁右翼中旗| 布尔津| 汤阴| 大通| 从化| 武进| 遵义县| 泰和| 聂拉木| 上饶市| 新田| 额济纳旗| 敦煌| 合浦| 南涧| 漠河| 淮阳| 河南| 淄川| 桐城| 南县| 沂南| 增城| 都安| 鄂州| 本溪市| 辽中| 曹县| 宁海| 菏泽| 戚墅堰| 府谷| 灌阳| 福鼎| 浮梁| 昌都| 诸城| 前郭尔罗斯| 咸宁| 承德县| 南漳| 涟水|
0

我的帖子

个人中心

设置

  发新话题
既然是路由选路,而且是链路状态型路由协议选路问题,这个就比较复杂一些。提到选路或负载就首先想

到ospf的选路原则,原则如下

OSPF选路原则:

1:O路由>O ia路由>external路由(E1,N1,E2,N2)

2:external-type-1(E1,N1)>external-tyle-2(E2,N2)

3:都为external-tyle-1,cost(外部开销+到ASBR开销)越小越优先。(外部开销默认重分配进OSPF为20

但BGP重分配进OSPF为1。)

4:都为external-tyle-1,cost也相等,那么E1>N1.

5:都为E1或都为N1,cost也相等,那么进行负载均衡

6:都为external-tyle-2,cost(只外部开销)越小越优先。(外部开销默认重分配进OSPF为20但BGP重分

配进OSPF为1。)

7:都为external-tyle-2,cost也相等,到ASBR路由器cost小的路径优先

8:都为external-tyle-2,cost也相等,到ASBR路由器cost也相等,那么E2优于N2

9:都为E2或都为N2,cost也相等,到ASBR路由器cost也相等,那么进行负载均衡



拓扑如下,ip规划如图




用AR1的环回口lo1模拟 192.168.2.0 /24 网段
用AR4的lo1 环回口 模拟 172.16.1.0 /24 网段

要求:当192.168.2.0 子网的客户访问 172.16.1.0 子网的客户时候 走的是ar2路由器,当回包的时候,

也就是 172.16.1.0 子网里的客户访问192.168.2.0子网里的客户时候走的的 ar3路由器,这样就 实现了

负载分担,当其中有一条线断掉,立马都走另一条线,这样就实现了网络冗余能力。

当我们对照选路原则的时候很无奈的发现,每一条都不适合我们,因为你怎么去调参数都会发现 两条路

由都是同步的,很难做到分开走。具体解决方法看我的配置。

ar1 配置

sysname r1
#
snmp-agent local-engineid 800007DB03000000000000
snmp-agent
#
clock timezone China-Standard-Time minus 08:00:00
#
portal local-server load portalpage.zip
#
drop illegal-mac alarm
#
set cpu-usage threshold 80 restore 75
#
aaa
authentication-scheme default
authorization-scheme default
accounting-scheme default
domain default
domain default_admin
local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$
local-user admin service-type http
#
firewall zone Local
priority 15
#
interface GigabitEthernet0/0/0
ip address 12.1.1.1 255.255.255.0
#
interface GigabitEthernet0/0/1
ip address 13.1.1.1 255.255.255.0
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
interface LoopBack0
ip address 1.1.1.1 255.255.255.0
#
interface LoopBack1
ip address 192.168.2.1 255.255.255.0
ospf network-type broadcast
#
ospf 1 router-id 1.1.1.1
nexthop 12.1.1.2 weight 1
area 0.0.0.0
  network 12.1.1.1 0.0.0.0
  network 13.1.1.1 0.0.0.0
  network 192.168.2.1 0.0.0.0
#
user-interface con 0
authentication-mode password
user-interface vty 0 4
user-interface vty 16 20
#
wlan ac
#
return






ar4 配置

sysname r3
#
snmp-agent local-engineid 800007DB03000000000000
snmp-agent
#
clock timezone China-Standard-Time minus 08:00:00
#
portal local-server load portalpage.zip
#
drop illegal-mac alarm
#
set cpu-usage threshold 80 restore 75
#
aaa
authentication-scheme default
authorization-scheme default
accounting-scheme default
domain default
domain default_admin
local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$
local-user admin service-type http
#
firewall zone Local
priority 15
#
interface GigabitEthernet0/0/0
ip address 34.1.1.4 255.255.255.0
#
interface GigabitEthernet0/0/1
ip address 24.1.1.4 255.255.255.0
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
interface LoopBack0
ip address 4.4.4.4 255.255.255.0
#
interface LoopBack1
ip address 172.16.1.1 255.255.255.0
ospf network-type broadcast
#
ospf 1 router-id 4.4.4.4
nexthop 34.1.1.3 weight 1
area 0.0.0.0
  network 24.1.1.4 0.0.0.0
  network 34.1.1.4 0.0.0.0
  network 172.16.1.1 0.0.0.0
#
user-interface con 0
authentication-mode password
user-interface vty 0 4
user-interface vty 16 20
#
wlan ac
#
return



其他两个路由器配置很普通



感谢分享!辛苦了!勉强看得懂一点 曾经我也埋头配置过这些,后来又放弃了,现在彻底忘了



宝剑厉不厉害,要看它的主人是谁,不信来PHP版块看看~!
引用:
原帖由 七彩极 于 2017-8-23 11:59 发表
感谢分享!辛苦了!勉强看得懂一点 曾经我也埋头配置过这些,后来又放弃了,现在彻底忘了
我想知道是什么原因让你把埋着的头抬起来了  o(∩_∩)o



引用:
原帖由 zhaoxixc 于 2017-9-1 13:57 发表

我想知道是什么原因让你把埋着的头抬起来了  o(∩_∩)o
没有从事这行,用不上



宝剑厉不厉害,要看它的主人是谁,不信来PHP版块看看~!
为什么还要配置 nexthop 34.1.1.3 weight 1
修改AR1和AR4上的入口开销值不就可以实现吗?



感谢分享,很多年前研究学习过很多次,结果这么多年过去了一次没用上!
又温故了一下!



亲可以再分享一下三台交换机互联使用的技术和配置方法!记得好像是叫stp吧,时间长了没用都忘记了



引用:
原帖由 beyongliao 于 2017-9-13 11:33 发表
为什么还要配置 nexthop 34.1.1.3 weight 1
修改AR1和AR4上的入口开销值不就可以实现吗?
呵呵,你改了,学到的路由 的cost是一样的。你怎么区分呢?你一改大家都改了。



"大师,什么是快乐的秘诀?"
"不要和愚者争论."
"大师,我完全不同意这就是秘诀."
"是的,你是对的。"
感谢分享!辛苦了!埋头苦学!






嘿嘿,先收着,用的时候照这个配,还不是美滋滋
感谢大神啊



为什么要做出入路径不一致呢?主备是有什么缺陷么。



楼主走的好一手异步路由!



刚刚接触这个,来学习一下。



‹‹ 上一贴:关于网闸和防火墙请教大神个问题。。。我迷茫啊 ...   |   下一贴:各位师傅们,请教抓包技术 ››
  发新话题
快速回复主题
关于我们 | 诚聘英才 | 联系我们 | 网站大事 | 友情链接 |网站地图
Copyright©2005-2017 51CTO.COM
本论坛言论纯属发布者个人意见,不代表51CTO网站立场!如有疑义,请与管理员联系:bbs@51cto.com
花瓶屿论坛 大同论坛 法石真武论坛 麻江县论坛 凉州区论坛
城东区论坛 泽当论坛 石嘴山论坛 浪茄论坛 镇平县论坛